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1. Introdução
O R Commander (Fox, 2005, 2017) fornece uma interface gráfica com o usuário ("GUI") para o 
ambiente de computação estatística de código aberto R (R Core Team, 2019). Este manual é uma 
introdução breve e básica ao R Commander; para obter uma documentação mais abrangente, 
consulte Fox(2017), que tem um site em <soc-serv.mcmaster.ca/jfox/Books/RCommander/> ou 
<tinyurl.com/RcmdrBook>.

O R é um sistema orientado por comandos, e os novos usuários geralmente acham o 
aprendizado do R desafiador. Isso é particularmente verdadeiro para aqueles que são novos nos 
métodos estatísticos, como os estudantes de cursos de estatística básica. Ao fornecer uma interface 
de apontar e clicar para R, o R Commander permite que esses usuários se concentrem nos métodos 
estatísticos, em vez de lembrar e formular comandos R. Além disso, ao tornar os comandos gerados 
visíveis para os usuários, o R Commander tem o potencial de facilitar a transição para escrita de  
comandos R, pelo menos para alguns usuários. O R Commander, no entanto, acessa apenas uma 
pequena fração dos recursos do R e os milhares de pacotes R literalmente contribuídos pelos 
usuários para a Rede Compreensiva de Arquivamento R (CRAN). O R Commander é extensível por
meio de pacotes de plug-ins, e muitos desses plug-ins estão agora disponíveis no CRAN (consulte a 
Seção 6.4 deste documento).

Este documento descreve diretamente o uso do R Commander na versão Windows do R. Há 
pequenas diferenças na aparência e no uso do R Commander no Mac OS X e nos sistemas Linux e 
Unix. Informações sobre a instalação do R Commander nessas plataformas estão disponíveis no link
para as notas de instalação na página da web do R Commander 
<socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/index.html> ou em <tinyurl.com / Rcmdr>.

Usamos as seguintes convenções tipográficas neste documento: Os nomes de software, 
como Windows, R, o pacote Rcmdr e o R Commander, são definidos em negrito. Os nomes dos 
elementos da GUI, como menus, itens de menu, janelas e caixas de diálogo, são definidos em 
itálico. Nomes de variáveis, nomes de conjuntos de dados e comandos R são definidos em uma 
fonte de máquina de escrever.

2 Iniciando o R Commander
Quando o R estiver em execução, basta carregar o pacote Rcmdr digitando o comando 
library(Rcmdr) no R Console para iniciar a interface gráfica do usuário do R Commander. Para 
funcionar de maneira ideal no Windows, o R Commander prefere a interface de documento único 
(“SDI”) para R. Depois de carregar o pacote, as janelas R Console e R Commander devem aparecer 
mais ou menos como nas Figuras 1 e 2. Outras imagens de tela neste documento foram criadas no 
Windows 7 e 10; se você usar outra versão do Windows (ou, é claro, outra plataforma de 
computação), a aparência da tela poderá ser diferente. As janelas do R Commander e do R Console 
flutuam livremente na área de trabalho. Você normalmente usará os menus e caixas de diálogo do R 
Commander para ler, manipular e analisar dados e pode minimizar com segurança a janela do R 
Console.



Figura 1: A janela do console R após carregar o pacote Rcmdr.

• Os comandos R gerados pela GUI do R Commander aparecem na guia Script R no painel 
superior da janela principal do R Commander. Você também pode digitar comandos R 
diretamente no painel de scripts; o principal objetivo do R Commander, no entanto, é evitar
a necessidade de digitar comandos. A segunda guia no painel superior (rotulada R 
Markdown) também acumula os comandos produzidos pelo R Commander e pode ser 
usada para gerar relatórios impressos; a guia R Markdown é descrita na Seção 6.1.

• A saída impressa aparece por padrão no segundo painel (rotulado como Output).
• O painel cinza inferior (Messages) exibe mensagens de erro, avisos e algumas outras 

informações (“notes”), como a mensagem de inicialização na Figura 2. 
• Quando você cria gráficos, eles aparecerão em uma janela separada Graphics Device.



Figura 2: A janela do R Commander na inicialização.

Existem vários menus na parte superior da janela do R Commander:

File Itens de menu para carregar e salvar arquivos de script; para salvar a saída e o espaço de 
trabalho R; e para sair.
Edit itens de menu (Recortar, Copiar, Colar etc.) para editar texto nos vários painéis e guias. Clicar 
com o botão direito do mouse em um desses painéis ou guias também exibe um menu de edição de 
"contexto".
Data Submenus de dados que contêm itens de menu para ler e manipular dados.



Statistics Submenus Estatísticas contendo itens de menu para uma variedade de análises 
estatísticas.
Graphs Itens de menu para criar vários gráficos estatísticos.
Models Itens de menu e submenus para obter resumos numéricos, intervalos de confiança, testes de 
hipóteses, diagnósticos e gráficos para um modelo estatístico e para adicionar quantidades de 
diagnóstico, como resíduos, ao conjunto de dados.
Distributions Submenus Distributions para obter probabilidades cumulativas, densidades ou 
massas de probabilidade, quantis e gráficos de distribuições estatísticas padrão (a serem usadas, por 
exemplo, como substituto de tabelas estatísticas) e para gerar amostras a partir dessas distribuições.
Tools Itens de menu para carregar pacotes R não relacionados ao pacote Rcmdr (por exemplo, para
acessar dados salvos em outro pacote); para carregar pacotes de plug-in Rcmdr (consulte Fox, 
2017, Fox, 2007, Fox e Sá Carvalho, 2012 e Seção 6.4 abaixo); para definir a maioria das opções do
R Commander e salvar as opções para que sejam aplicadas nas sessões subseqüentes; e para 
instalar o software auxiliar opcional (consulte a Seção 6.1).
Help Itens do menu para obter informações sobre o R Commander (incluindo este manual) e o 
software associado. Além disso, cada caixa de diálogo R Commander possui um botão Help (veja 
abaixo).

O menu completo em “árvore” para o R Commander (versão 2.4-0) é mostrado abaixo. A 
maioria dos itens de menu leva a caixas de diálogo, conforme ilustrado mais adiante neste manual, 
e, como é convencional, esses itens de menu são seguidos por ... Os itens de menu ficam inativos 
(“acinzentados”) se não forem aplicáveis ao contexto atual. Por exemplo, se um conjunto de dados 
não contiver fatores (variáveis categóricas), os itens de menu para tabelas de contingência ficarão 
inativos.

Arquivo
| - Alterar diretório de trabalho ...
| - Abrir arquivo de script ...
| - Salvar script ...
| - Salvar script como ...
| - Abrir arquivo R Markdown ...
| - Salvar arquivo R Markdown ...
| - Salvar arquivo R Markdown como ...
| - Salvar saída ...
| - Salvar saída como ...
| - Salvar espaço de trabalho R ...
| - Salvar espaço de trabalho R como ...
| - Sair
| | - Do Commander
| | - Do Commander e do R
Editar
| - Editar documento R Markdown
| - Editar documento knitr
| - Remover o último bloco de comandos Markdown
| - Remover o último bloco de comandos do knitr
| - Corte
| - Copiar
| - Colar



| - Excluir
| - Localizar
| - Selecionar tudo
| - Desfazer
| - Refazer
| - Limpar janela
Dados
| - Novo conjunto de dados ...
| - Carregar conjunto de dados ...
| - Mesclar conjuntos de dados ...
| - Importar dados
| | - de arquivo de texto, área de transferência ou URL ...
| | - do conjunto de dados SPSS ...
| | - do arquivo SAS xport ...
| | - do arquivo SAS b7dat ...
| | - do conjunto de dados do Minitab ...
| | - do conjunto de dados STATA ...
| | - do arquivo do Excel ...
| - Dados em pacotes
| | - Listar conjuntos de dados em pacotes
| | - Ler o conjunto de dados de um pacote anexado ...
| - Conjunto de dados ativo
| | - Exibir dados ...
| | - Selecione o conjunto de dados ativo ...
| | - Atualizar conjunto de dados ativo
| | - Ajuda no conjunto de dados ativo (se disponível)
| | - Variáveis no conjunto de dados ativo
| | - Definir nomes dos casos ...
| | - Conjunto de dados ativos do subconjunto ...
| | - Classificar conjunto de dados ativo ...
| | - Agregar variáveis no conjunto de dados ativo ...
| | - Remover linha(s) do conjunto de dados ativo ...
| | - Empilhar variáveis no conjunto de dados ativo ...
| | - Remover casos com dados ausentes ...
| | - Salvar conjunto de dados ativo ...
| | - Exportar conjunto de dados ativo ...
| - Gerenciar variáveis no conjunto de dados ativo
| | - Recodificar variáveis ...
| | - Calcular nova variável ...
| | - Adicionar números de observação ao conjunto de dados
| | - Padronizar variáveis ...
| | - Converter variáveis numéricas em fatores ...
| | - Variável numérica do compartimento ...
| | - Reordenar níveis de fator ...
| | - Retire os níveis de fator não utilizados ...



| | - Definir contrastes para um fator …
| | - Renomear variáveis ...
| | - Excluir variáveis do conjunto de dados ...
Estatisticas
| - Resumos
| | - Conjunto de dados ativo
| | - Resumos numéricos ...
| | - Distribuições de frequências ...
| | - Contar observações ausentes
| | - Tabela de estatísticas ...
| | - Matriz de correlação ...
| | - Teste de correlação ...
| | - Teste de normalidade ...
| - Tabelas de Contingência
| | - Tabela de duas entradas ...
| | - Tabela de múltipla entrada ...
| | - Digite e analise a tabela de duas entradas ...
| - Médias
| | - Teste t de amostra única ...
| | - Teste t de amostras independentes ...
| | - Teste t emparelhado ...
| | - ANOVA univariada ...
| | - ANOVA múltipla entrada ...
| - Proporções
| | - Teste de proporção de amostra única ...
| | - Teste de proporção de duas amostras ...
| - Variâncias
| | - Teste F de duas variâncias ...
| | - Teste de Bartlett ...
| | - Teste de Levene ...
| - Testes não paramétricos
| | - Teste de Wilcoxon para duas amostras ...
| | - Teste de Wilcoxon para uma amostra ...
| | - Teste de Wilcoxon para amostras emparelhadas …
| | - Teste de Kruskal-Wallis ...
| | - Teste de soma dos postos de Friedman ...
| - Análise dimensional
| | - Escala de confiabilidade ...
| | - Análise de componentes principais ...
| | - Análise fatorial ...
| | - Análise fatorial confirmatória ...
| | - Análise de cluster
| | | - análise de agrupamentos k-means ...
| | | - Análise hierárquica de agrupamentos ...
| | | - Resumo do cluster hierárquico ...



| | | - Adicionar cluster hierárquico ao conjunto de dados ...
| - Ajuste de Modelos
| | - Regressão linear ...
| | - Modelo linear ...
| | - Modelo linear generalizado ...
| | - Modelo logit multinomial ...
| | - Modelo de regressão ordinal ...
| | - Modelo linear misto ...
| | - Modelo misto linear generalizado ...
Gráficos
| - Paleta de cores ...
| - Gráfico de índice ...
| - Gráfico de pontos ...
| - Histograma ...
| - Plotar variável numérica discreta ......
| - Estimativa de densidade ...
| - Gráfico de ramos e folhas ...
| - Boxplot ...
| - Gráfico de comparação quantílica ...
| - Gráfico de dispersão ...
| - Matriz de dispersão ...
| - Gráfico de linha ...
| - Gráfico de condicionamento XY ...
| - Gráfico de médias ...
| - Gráfico de tiras ...
| - Gráfico de barras ...
| - Gráfico de pizza ...
| - Gráficos 3D
| | - Gráfico de dispersão 3D ...
| | - Identificar observações com o mouse
| | - Salvar gráfico em arquivo
| - Salvar gráfico em arquivo
| | - como bitmap ...
| | - como PDF / Postscript / EPS ...
| | - Gráfico 3D RGL …
Modelos
| - Selecione o modelo ativo ...
| - Resumir modelo
| - Comparar coeficientes do modelo ...
| - Adicionar estatísticas das observações aos dados ...
| - Critério de informação de Akaike (AIC)
| - Critério de informação bayesiano (BIC)
| - Seleção de modelo por etapas ...
| - Seleção de modelo de subconjunto ...
| - Intervalos de confiança ......



| - Intervalos de confiança bootstrap ...
| - Intervalo de confiança do método Delta ...
| - Testes de hipóteses
| | - tabela de ANOVA ...
| | - Comparar dois modelos ...
| | - Hipótese linear ...
| - Diagnóstico numérico
| | - Fatores de variação e inflação
| | - Teste Breusch-Pagan para heterocedasticidade ...
| | - Teste de Durbin-Watson para autocorrelação ...
| | - Teste RESET para não linearidade ...
| | - Teste de outlier de Bonferroni
| - Gráficos
| | - Gráficos básicos de diagnóstico
| | - Gráfico de comparação quantílica residual ...
| | - Gráfico componente + resíduos ...
| | - Gráficos de variáveis adicionadas ...
| | - Gráfico de influência ...
| | - Gráfico de índice de influência ...
| | - Gráficos de efeito ...
| | - Gráficos de efeito preditor ...
Distribuições
| - Definir semente geradora de número aleatório …
| - Distribuições contínuas
| | - Distribuição normal
| | | - Quantis normais ...
| | | - Probabilidades normais ...
| | | - Traçar a distribuição normal ...
| | | - Amostra da distribuição normal ...
| | - distribuição t
| | | - quantis t ...
| | | - probabilidades t ...
| | | - Traçar a distribuição t ...
| | | - Amostra da distribuição t ...
| | - Distribuição qui-quadrado
| | | - Quantis qui-quadrado ...
| | | - Probabilidades qui-quadrado ...
| | | - Traçar distribuição qui-quadrado ...
| | | - Amostra da distribuição qui-quadrado ...
| | - Distribuição F
| | | - Quantis F ...
| | | - Probabilidades F ...
| | | - Traçar a distribuição F ...
| | | - Amostra da distribuição F ...
| | - Distribuição exponencial



| | | - Quantis exponenciais ...
| | | - Probabilidades exponenciais ...
| | | - Traçar distribuição exponencial ...
| | | - Amostra de distribuição exponencial ...
| | - Distribuição uniforme
| | | - Quantis uniformes ...
| | | - Probabilidades uniformes ...
| | | - Traçar distribuição uniforme ...
| | | - Amostra de distribuição uniforme ...
| | - Distribuição beta
| | | - Quantis beta ...
| | | - Probabilidades beta ...
| | | - Gráfico da distribuição beta ...
| | | - Amostra da distribuição beta ...
| | - Distribuição Cauchy
| | | - Quantis de Cauchy ...
| | | - Probabilidades de Cauchy ...
| | | - Gráfico da distribuição Cauchy ...
| | | - Amostra da distribuição Cauchy ...
| | - Distribuição logística
| | | - Quantis logísticos ...
| | | - Probabilidades logísticas ...
| | | - Distribuição logística de plotagem ...
| | | - Amostra da distribuição logística …
| | - Distribuição lognormal
| | | - Quantis lognormal ...
| | | - Probabilidades lognormal ...
| | | - Traçar distribuição lognormal ...
| | | - Amostra da distribuição lognormal ...
| | - Distribuição gama
| | | - Quantis gama ...
| | | - Probabilidades gama ...
| | | - Plotar distribuição gama ...
| | | - Amostra da distribuição gama ...
| | - Distribuição Weibull
| | | - Quantis Weibull ...
| | | - Probabilidades Weibull ...
| | | - Traçar a distribuição Weibull ...
| | | - Amostra da distribuição Weibull ...
| | - Distribuição Gumbel
| | | - Quantis de Gumbel ...
| | | - Probabilidades de Gumbel ...
| | | - Traçar a distribuição de Gumbel ...
| | | - Amostra da distribuição Gumbel ...
| - Distribuições discretas



| | - Distribuição binomial
| | | - Quantis binomiais ...
| | | - Probabilidades da cauda binomial ...
| | | - Probabilidades binomiais ...
| | | - Traçar a distribuição binomial ...
| | | - Amostra da distribuição binomial ...
| | - Distribuição de Poisson
| | | - Quantis de Poisson ...
| | | - Probabilidades da cauda de Poisson ...
| | | - Probabilidades de Poisson ...
| | | - Traçar a distribuição de Poisson ...
| | | - Amostra da distribuição Poisson …
| | - Distribuição geométrica
| | | - Quantis geométricos ...
| | | - Probabilidades geométricas da cauda ...
| | | - Probabilidades geométricas ...
| | | - Traçar a distribuição geométrica ...
| | | - Amostra da distribuição geométrica ...
| | - Distribuição hipergeométrica
| | | - Quantis hipergeométricos ...
| | | - Probabilidades hipergeométricas da cauda ...
| | | - Probabilidades hipergeométricas ...
| | | - Traçar a distribuição hipergeométrica ...
| | | - Amostra da distribuição hipergeométrica ...
| | - Distribuição binomial negativa
| | | - Quantis binomiais negativos ...
| | | - Probabilidades negativas da cauda binomial ...
| | | - Probabilidades binomiais negativas ...
| | | - Traçar a distribuição binomial negativa ...
| | | - Amostra da distribuição binomial negativa ...
Ferramentas
| - Carregar pacote(s) ...
| - Carregar plug-in(s) Rcmdr ...
| - Opções ...
| - Salvar opções do Rcmdr ...
| - Gerenciar soneca do aplicativo Mac OS X para R.app ...
| - Instale o software auxiliar ...
Ajuda
| - Ajuda do R commander
| - Introdução ao R commander
| - Site do R commander
| - Sobre Rcmdr
| - Autocolante hexadecimal R Commander
| - Ajuda no conjunto de dados ativo (se disponível)
| - Iniciar o sistema de ajuda do R



| - Site do R
| - Usando R Markdown

A interface do R Commander inclui alguns elementos, além de menus e caixas de diálogo:

• Abaixo dos menus, há uma "barra de ferramentas" com uma linha de botões.
◦ O botão mais à esquerda mostra o nome do conjunto de dados ativo. Inicialmente, não 

há conjunto de dados ativo. Se você pressionar esse botão, poderá escolher entre os 
conjuntos de dados atualmente na memória (se houver mais de um). A maioria dos 
menus e caixas de diálogo no R Commander faz referência ao conjunto de dados ativo. 
(Os menus Arquivo (File) , Editar (Edit) e Distribuições (Distributions) são exceções.) 

◦ Dois botões permitem abrir o editor de dados do R Commander para modificar o 
conjunto de dados ativo ou um visualizador para examiná-lo. O visualizador do conjunto
de dados pode permanecer aberto enquanto outras operações são executadas e a exibição
é atualizada se o conjunto de dados for modificado, por exemplo, adicionando uma 
variável.

◦ Um botão simples indica o nome do modelo estatístico ativo - um modelo linear (como 
um modelo de regressão linear), um modelo linear generalizado, um modelo de logit 
multinomial ou um modelo de regressão ordinal. Inicialmente não há modelo ativo. Se 
houver mais de um modelo na memória associado ao conjunto de dados ativo, você 
poderá escolher entre os modelos pressionando o botão. O R Commander sincroniza os
modelos e os conjuntos de dados aos quais eles se ajustam.

• Imediatamente abaixo da barra de ferramentas, há um painel que contém a guia R Script, 
uma grande janela de texto rolável. Como mencionado, os comandos gerados pelo R 
Commander são copiados nessa janela. Você pode editar o texto na guia Script ou até 
digitar seus próprios comandos R na janela. Pressionar o botão Submit, localizado logo 
abaixo da guia Script (ou, alternativamente, a combinação de teclas Ctrl-r, para "executar" 
ou Ctrl-Tab), faz com que a linha que contém o cursor seja enviada (ou reenviada)) para 
execução. Se várias linhas forem selecionadas (por exemplo, clicando com o botão esquerdo
e arrastando o mouse sobre elas), pressionar Submit fará com que todas sejam executadas. 
Os comandos inseridos na guia R Script podem se estender por mais de uma linha, mas 
todas as linhas devem ser enviadas simultaneamente. A combinação de teclas Ctrl-a 
seleciona todo o texto na guia Script e Ctrl-s exibe uma caixa de diálogo para salvar o 
conteúdo da guia. A guia R Markdown é descrita na Seção 6.1.

• Abaixo das guias R Script e R Markdown, há um painel que contém uma grande janela de 
texto editável e rolável para Output. Os comandos ecoados no painel Output aparecem em 
vermelho, a saída resultante em azul escuro (como no Windows R Console padrão).

• Na parte inferior, há um pequeno painel cinza para Messages. As mensagens de erro são 
exibidas em texto vermelho, os avisos em verde e outras mensagens em azul escuro. Erros e 
avisos também fornecem um sinal sonoro tocando uma campainha.

Como mencionado, depois de carregar o pacote Rcmdr, você pode minimizar o R Console. 
A janela do R Commander também pode ser redimensionada ou maximizada da maneira normal. Se 
você redimensionar o R Commander, a largura da saída R subsequente será ajustada 
automaticamente para caber no painel Output.



O R Commander é altamente configurável: descrevemos a configuração padrão aqui. 
Alterações na configuração podem ser feitas através de Tools → Options. . ., ou - mais 
extensivamente - configurando as opções de R Commander no R. Consulte Help → Commander 
help para obter detalhes.

3 Entrada de Dados
A maioria dos procedimentos no R Commander pressupõe que haja um conjunto de dados ativo. 
Se houver vários conjuntos de dados na memória, você poderá escolher entre eles, mas apenas um 
estará ativo. Quando o R Commander inicia, não há um conjunto de dados ativo.

O R Commander fornece várias maneiras de inserir dados no R:
• Usando o editor de dados do R Commander, é possível inserir dados diretamente via Data  

→ New data set .... Essa é uma opção razoável apenas para um conjunto de dados muito 
pequeno.

• Você pode importar dados de um arquivo de texto sem formatação ("ascii") ou da área de 
transferência, pela Internet, a partir de um URL, de outro pacote estatístico (Minitab, SPSS,
SAS ou Stata) ou de uma planilha do Excel.

• Você pode ler um conjunto de dados incluído em um pacote R, digitando o nome do 
conjunto de dados (se você o conhece) ou selecionando o conjunto de dados em uma caixa 
de diálogo.

3.1 Lendo dados de um arquivo de texto
Por exemplo, considere o arquivo de dados Nations.txt. As primeiras linhas do arquivo são as 
seguintes:

TFR contraception infant.mortality GDP region
Afghanistan 6.90 NA 154 2848 Asia
Albania 2.60 NA 32 863 Europe
Algeria 3.81 52 44 1531 Africa
American-Samoa NA NA 11 NA Oceania
Andorra NA NA NA NA Europe
Angola 6.69 NA 124 355 Africa
Antigua NA 53 24 6966 Americas
Argentina 2.62 NA 22 8055 Americas
Armenia 1.70 22 25 354 Europe
Australia 1.89 76 6 20046 Oceania
. . .

• A primeira linha do arquivo contém nomes de variáveis: TFR (taxa total de fertilidade, 
expressa como número de filhos por mulher), contraception (taxa de uso de 
contraceptivos entre mulheres casadas, em porcentagem), infant.mortality (taxa de 
mortalidade infantil por 1000 nascidos vivos), GDP (produto interno bruto per capita, em 
dólares dos EUA) e region.

• As linhas subsequentes contêm os próprios valores dos dados, uma linha por país. Os 
valores dos dados são separados por "espaço em branco" - um ou mais espaços em branco 
ou guias. Embora seja útil alinhar os valores dos dados verticalmente, não é necessário fazer
isso. Observe que as linhas de dados começam com os nomes dos países. Como queremos 
que esses sejam os “nomes das linhas” para o conjunto de dados, não há nome de variável 
correspondente: ou seja, existem cinco nomes de variáveis, mas seis valores de dados em 



cada linha, sendo o primeiro alfabético. Quando isso acontece, o comando R read.table 
interpreta o primeiro valor em cada linha como o nome da linha.

• Alguns dos valores dos dados estão ausentes. Em R, é mais conveniente usar NA 
(representando "não disponível") para codificar dados ausentes, como fizemos aqui.

• As variáveis TFR, contraception, infant.mortality e GDP são variáveis numéricas 
(quantitativas); por outro lado, regions contém nomes de regiões. Quando os dados são 
lidos, R tratará region como um "fator" - isto é, como uma variável categórica. Na maioria 
dos contextos, o R Commander distingue entre variáveis e fatores numéricos e tentará 
impedir que você faça coisas irracionais, como calcular a média de um fator.

Para ler o arquivo de dados Nations.txt no R, selecione Data → Import data → from text
file, clipboard ou URL ... nos menus do R Commander. Esta operação exibe um diálogo Read Text
Data, conforme mostrado na Figura 3. O nome padrão do conjunto de dados é Dataset. Nós 
mudamos o nome para Nations.

Os nomes R válidos começam com uma letra maiúscula ou minúscula (ou um ponto, .) e 
consistem inteiramente de letras, pontos, sublinhados (_) e numerais (ou seja, 0 a 9); em particular, 
não inclua espaços em branco incorporados no nome de um conjunto de dados. R faz distinção 
entre maiúsculas e minúsculas e, portanto, por exemplo, nations, Nations e NATIONS são 
distintas e podem ser usadas para representar conjuntos de dados diferentes.

Clicar no botão OK na caixa de diálogo Read Text Data abre uma caixa de diálogo Open file,
mostrada na Figura 4. Aqui navegamos e selecionamos o arquivo Nations.txt. Clicar no botão 
Open na caixa de diálogo faz com que o arquivo de dados seja lido. Depois que o arquivo de dados 
é lido, ele se torna o conjunto de dados ativo no R Commander. Como conseqüência, na Figura 5, 
o nome do conjunto de dados aparece no botão do conjunto de dados próximo ao canto superior 
esquerdo da janela do R Commander. O comando para ler o conjunto de dados do Nations (o 
comando R read.table) aparece na guia R Script e no painel Output. Além disso, quando o 
conjunto de dados é lido e se torna o conjunto de dados ativo, uma nota aparece no painel 
Messages.

Em seguida, clicamos no botão View data set para abrir a janela do visualizador de dados, 
também mostrada na Figura 5.

O comando read.table cria um "quadro de dados" R, que é um objeto que contém um 
conjunto de dados retangular de casos por variáveis: As linhas do conjunto de dados representam 
casos ou observações e as colunas representam variáveis. Os conjuntos de dados no R Commander
são data frames R.



Figura 4: Caixa de diálogo de Open file para ler um arquivo de dados de texto.



Figura 5: Exibindo o conjunto de dados ativo.



Figura 6: Editor de dados após a inserção dos dados.

3.2 Inserindo dados diretamente
Você pode inserir dados diretamente no editor de dados do tipo planilha básica do R Commander. 
Uma alternativa simples, que de fato preferimos, é salvar os dados em um arquivo de texto sem 
formatação (tenha cuidado, se você criar o arquivo de dados com um processador de texto, salvá-lo 
como um texto sem formatação ou arquivo "ascii") , normalmente com o tipo de arquivo .txt e, 
em seguida, para ler o arquivo como na seção anterior, via Data → Import data → from text file, 
clipboard, ou URL .... Se seus dados já estiverem em um programa de planilha, como o Excel, você 
poderá simplesmente exportá-los para um arquivo de texto com valores separados por vírgula 
(arquivo .csv) e ler o arquivo no R Commander, tomando cuidado para especificar o campo 
separador como vírgula. Lembre-se de que você também pode ler uma planilha do Excel 
diretamente. Como exemplo de entrada direta de dados, usamos um conjunto de dados muito 
pequeno do Problema 2.44 em Moore(2000):

• Selecione Data → New data set... nos menus do R Commander. Opcionalmente, insira um 
nome para o conjunto de dados, como o Problema2.44, na caixa de diálogo resultante e 
clique no botão OK. (Lembre-se de que os nomes R não podem incluir espaços em branco 
incorporados.) Isso exibirá uma janela Data Editor com um conjunto de dados vazio.

• Insira os dados do problema nas duas primeiras colunas do editor de dados. Adicione uma 
coluna clicando no botão Adicionar coluna na barra de ferramentas do editor de dados ou 
selecionando Add column no menu Edit. Da mesma forma, adicione linhas ao conjunto de 
dados clicando no botão Add row repetidamente ou no menu Edit. Você também pode 
adicionar uma linha pressionando a tecla Enter ou adicionar uma coluna pressionando a 
tecla Tab quando o cursor estiver em uma célula na tabela de dados.

• Você pode mover-se de uma célula para outra usando as teclas de seta do teclado ou 
apontando com o mouse e clicando com o botão esquerdo. Originalmente, as variáveis são 
nomeadas var1 e var2, e os valores dos dados são todos NA (ou seja, ausentes). Quando 
você digita um novo nome de variável, nome de linha ou valor de dados em uma célula do 
editor de dados, o novo valor substitui o que estava anteriormente lá. Se você clicar duas 
vezes em uma célula, a célula se tornará NA. Quando você terminar de inserir os dados, a 
janela do editor de dados deverá se parecer com a Figura 6.



• Neste exemplo, ambas as variáveis são numéricas. Se você digitar algum valor não 
numérico em uma coluna no editor de dados (que não seja o valor ausente NA), a coluna 
definirá um fator (variável categórica) no novo conjunto de dados.

• Selecione File →Exit and save nos menus do Data Editor ou clique no botão OK. O 
conjunto de dados que você inseriu agora é o conjunto de dados ativo no R Commander.

Figura 7: Leitura de dados de um pacote anexado - neste caso, o conjunto de dados Prestige do 
pacote car.

3.3 Lendo dados de um pacote

Muitos pacotes R incluem dados. Os conjuntos de dados em pacotes podem ser listados em uma 
janela pop-up via Data → Data in packages → List data sets in packages e podem ser lidos no R 
Commander via Data → Data in packages → Read data set from an attached package. A caixa de 
diálogo resultante é mostrada na Figura 7. Se você souber o nome de um conjunto de dados em um 
pacote, poderá inserir seu nome diretamente; caso contrário, clicar duas vezes no nome de um 
pacote exibe seus conjuntos de dados na caixa de listagem à direita; e clicar duas vezes no nome de 
um conjunto de dados copia o nome para o campo de entrada do conjunto de dados na caixa de 
diálogo. Pressionar uma tecla da letra na caixa de listagem Data set rolará até o próximo conjunto 
de dados cujo nome começa com essa letra. Você pode acessar pacotes R adicionais instalados na 
sua biblioteca de pacotes por Tools → Load packages.

4 Criando resumos numéricos e gráficos

Quando houver um conjunto de dados ativo, você poderá usar os menus do R Commander para 
produzir uma variedade de resumos e gráficos numéricos. Vamos descrever apenas alguns exemplos
básicos aqui. Uma boa GUI deve ser amplamente auto-explicativa. Se você preferir uma introdução 
mais abrangente ao R Commander, consulte Fox(2017).

Nos exemplos iniciais abaixo, assumimos que o conjunto de dados ativo é o conjunto de 
dados Nations, lido de um arquivo de texto na seção anterior. Se você digitou o conjunto de dados 
de cinco observações de Moore (2000) ou leu o conjunto de dados Prestige do pacote car - 
operações que também foram descritas na seção anterior -, um deles é o conjunto de dados ativo. 
Lembre-se de que você pode alterar o conjunto de dados ativo clicando no botão com o nome do 



conjunto de dados ativo próximo à parte superior esquerda da janela do R Commander, escolhendo
entre uma lista de conjuntos de dados atualmente residentes na memória.

Selecionando Statistics → Summaries → Active data set produz os resultados mostrados na 
Figura 8. Para cada variável numérica no conjunto de dados (TFR, contraception, 
infant.mortality e GDP), R relata os valores mínimo e máximo, o primeiro e o terceiro quartil, a
mediana e a média, juntamente com o número de valores ausentes. Para a variável categórica 
region, obtemos o número de observações em cada "nível" do fator. Se o conjunto de dados 
incluísse mais de dez variáveis, o R Commander nos perguntaria se realmente queremos 
prosseguir - potencialmente nos protegendo de produzir uma saída volumosa indesejada. Esse item 
de menu é incomum, pois invoca diretamente um comando R em vez de levar a uma caixa de 
diálogo, como é mais típico nos menus do R Commander.

Por exemplo, selecionar Statistics → Summaries → Numerical summaries... abre a caixa de 
diálogo na Figura 9. Somente variáveis numéricas aparecem na lista de variáveis nesta caixa de 
diálogo; o fator region é excluído porque não é sensato calcular resumos numéricos como a média 
e o desvio padrão de um fator.



Figura 8: Obtendo resumos de variáveis para o conjunto de dados ativo.



Figura 9: A guia Data na caixa de diálogo Numerical Summaries.

Figura 10: A guia Statistics na caixa de diálogo Numerical Summaries.

Selecionamos a variável infant.mortality clicando com o botão esquerdo do mouse nela. A 
caixa de diálogo Numerical Summaries possui duas guias: Data e Statistics. Clique na guia 
Statistics para selecioná-lo, como mostra a Figura 10. Nesse caso, faremos todas as seleções de 
estatísticas padrão. Clicar em OK produz a seguinte saída (no painel Output):

> numSummary(Nations[,"infant.mortality"], statistics=c("mean", "sd", "IQR",
+      "quantiles"), quantiles=c(0,.25,.5,.75,1))

mean sd IQR 0% 25% 50% 75% 100% n NA
43.47761 38.75604 54 2 12 30 66 169 201 6



Por padrão, o comando R que é executado imprime a média, desvio padrão (sd) e intervalo 
interquartil (IQR) da variável, juntamente com quantis (percentis) correspondentes ao mínimo, o 
primeiro quartil, a mediana, o terceiro quartil e o máximo; n é o número de obserações válidas e NA,
o número de valores ausentes.

Como é típico das caixas de diálogo R Commander, a caixa de diálogo Numerical 
Summaries na Figura 9 inclui os botões Help, Reset, OK, Cancel e Apply. O botão Help leva a uma 
página de ajuda (que aparece no seu navegador da Web) para a própria caixa de diálogo ou (como 
aqui) para uma função R que a caixa de diálogo chama. O botão Reset, presente na maioria das 
caixas de diálogo do R Commander, redefine a caixa de diálogo para o estado original; caso 
contrário, a caixa de diálogo manterá as seleções de uma chamada anterior. O estado da caixa de 
diálogo também é redefinido quando o conjunto de dados ativo é alterado. Como demonstrado, o 
botão OK fecha a caixa de diálogo e gera um comando R. O botão Apply também gera um 
comando, mas reabre a caixa de diálogo em seu estado atual, facilitando a aplicação de várias 
operações semelhantes. Se você cometer um erro em uma caixa de diálogo - por exemplo, clicando 
em OK sem escolher uma variável na caixa de diálogo Numerical Summaries - uma mensagem de 
erro geralmente aparecerá e a caixa de diálogo será reaberta.

A caixa de diálogo Numerical Summaries também fornece provisões para computação 
dentro de grupos definidos pelos níveis de um fator. Clicar no botão Summarize by groups... na guia
Data exibe a caixa de diálogo Groups, como mostra a Figura 11. Como existe apenas um fator no 
conjunto de dados das Nations, apenas a região variável aparece na lista de variáveis e está pré-
selecionado; clicar em OK altera o botão Summarize by groups ... para Summarize by region 
(consulte a Figura 12). Nesse caso, selecionamos duas variáveis numéricas para resumir, GDP e 
infant.mortality. Clicar em OK produz os seguintes resultados no painel Output:

Figura 11: Selecionando uma variável de agrupamento na caixa de diálogo Groups.



Figura 12: A caixa de diálogo Numerical Summaries após a variável de agrupamento region ter sido
escolhida e com duas variáveis numéricas selecionadas.

> numSummary(Nations[,c("GDP", "infant.mortality")], groups=Nations$region,
+ statistics=c("mean", "sd", "IQR", "quantiles"), quantiles=c(0,.25,.5,.75,1))

Variable: GDP
mean sd IQR 0% 25% 50% 75% 100% n NA

Africa 1196.000 2089.614 795.50 36 209.00 389.5 1004.50  11854  54  1

Americas 5398.000 6083.311 5268.50 386 1749.25 2765.5 7017.75  26037  40  1

Asia 4505.051 6277.738 6062.50 122 345.00 1079.0 6407.50  22898  39  2

Europe 13698.909 13165.412 24582.25 271 1643.75 9222.5 26226.00  42416  44  1

Oceania 8732.600 11328.708 16409.25 654 1102.75 2348.5 17512.00  41718  20  5

Variable: infant.mortality
mean sd IQR 0% 25% 50% 75% 100% n NA

Africa 85.27273 35.188095 50.0 7 61.00 85.0 111.00 169 55 0

Americas 25.60000 17.439713 24.0 6 12.00 21.5 36.00 82 40 1

Asia 45.65854 32.980001 50.0 5 22.00 37.0 72.00 154 41 0

Europe 11.85366 7.122363 10.0 5 6.00 8.0 16.00 32 41 4

Oceania 27.79167 29.622229 26.5 2 9.25 20.0 35.75 135 24 1

Várias outras caixas de diálogo do R Commander permitem selecionar uma variável de 
agrupamento dessa maneira.

Fazer gráficos com o R Commander também é simples. Por exemplo, selecionar Graphs 
→ Histogram... nos menus do R Commander produz a caixa de diálogo Histogram da Figura 13. 



Há guias Data e Options nessa caixa de diálogo. Tomaremos todas as opções padrão (a guia 
Options não é mostrada) e, clicando em infant.mortality, seguido de OK, abre uma janela 
Graphics Device com o histograma mostrado na Figura 14. Se você criar vários gráficos em uma 
sessão, então apenas o mais recente normalmente aparece na janela Graphics Device.

Figura 13: A caixa de diálogo Histograma.



Figura 14: Uma janela gráfica contendo o histograma da mortalidade infantil no conjunto de dados 
das Nations.



Figura 15: A caixa de diálogo Linear Model, com o Prestige do pacote car como o conjunto de 
dados ativo.

5 Modelos Estatísticos
Vários tipos de modelos estatísticos podem ser ajustados no R Commander usando os itens de 
menu em Statistics → Fit models: modelos lineares (por regressão linear e modelo linear), modelos
lineares generalizados, modelos de logon multinomiais e modelos de regressão ordinal, como os 
modelos de odds-proporcionais [os dois últimos dos pacotes nnet e MASS de Venables e Ripley, 
respectivamente (Venables e Ripley, 2002)]. Embora as caixas de diálogo resultantes sejam 
diferentes em certos detalhes (por exemplo, a caixa de diálogo do modelo linear generalizado prevê 
a seleção de uma família de distribuição e da função de ligação correspondente), elas compartilham 
uma estrutura geral comum, conforme ilustrado na caixa de diálogo Linear Model da Figura 15. 
Antes de selecionar Statistics → Fit models → Linear Model, tornamos o conjunto de dados  
Prestige ativo clicando no botão do conjunto de dados ativo e selecionando Prestige na lista 
resultante. Lembre-se de que os dados do Prestige foram lidos do pacote car na Seção 3.3.

• Clicando duas vezes numa variável na caixa de listagem de variáveis a seleciona para a 
fórmula do modelo - para o lado esquerdo da fórmula, se estiver vazio, ou para o lado direito
(com um sinal + anterior, se o contexto requerer). Fatores (variáveis categóricas - aqui, 
type) são rotulados entre parênteses como tal na lista de variáveis. Inserir um fator no lado 
direito de uma fórmula de um modelo estatístico gera regressores de variáveis dummy.

• A linha superior de botões na barra de ferramentas acima da fórmula pode ser usada para 
inserir operadores e parênteses no lado direito da fórmula.

• A linha inferior de botões na barra de ferramentas pode ser convenientemente usada para 
inserir termos de regressão spline e termos polinomiais na fórmula do modelo, com os graus 
de liberdade para splines e o grau dos polinômios controlados pelas caixas de anotação à 
direita da (padrão de 5 df e grau 2, respectivamente).



• Você também pode digitar diretamente nos campos da fórmula e, na verdade, pode precisar 
fazê-lo, por exemplo, para colocar um termo como log(income) na fórmula, como fizemos
aqui. Algumas informações sobre as fórmulas do modelo R podem ser obtidas pressionando 
o botão Model formula help na caixa de diálogo do modelo linear.

• O nome do modelo, aqui LinearModel.1, é gerado automaticamente, mas você pode 
substituir por qualquer nome R válido.

• Você pode digitar uma expressão R na caixa denominada Subset expression; se fornecido, 
isso é passado para o argumento do subconjunto da função lm e é usado para ajustar o 
modelo a um subconjunto das observações no conjunto de dados. Uma forma de expressão 
de subconjunto é uma expressão lógica avaliada como TRUE ou FALSE para cada 
observação, como type! = "prof" (que selecionaria todas as ocupações não profissionais 
do conjunto de dados Prestige).

• Opcionalmente ao selecionar uma variável de peso na lista de Weights produz uma 
regressão de mínimos quadrados ponderados (WLS).

Clicar no botão OK gera o seguinte comando e saída, e torna o LinearModel.1 o modelo 
ativo, com seu nome exibido no botão Model:

> LinearModel.1 <- lm(prestige ~ (education + log(income))*type,
+      data=Prestige)

> summary(LinearModel.1)

Call:
lm(formula = prestige ~ (education + log(income)) * type, data = 
Prestige)

Residuals:

Min 1Q Median 3Q Max
-13.970 -4.124 1.206 3.829 18.059

Coefficients:
Estimate Std. Error t value Pr(>|t|)

(Intercept) -120.0459 20.1576 -5.955 5.07e-08 ***
education 2.3357 0.9277 2.518 0.01360 *
log(income) 15.9825 2.6059 6.133 2.32e-08 ***
type[T.prof] 85.1601 31.1810 2.731 0.00761 **
type[T.wc] 30.2412 37.9788 0.796 0.42800
education:type[T.prof] 0.6974 1.2895 0.541 0.58998
education:type[T.wc] 3.6400 1.7589 2.069 0.04140 *
log(income):type[T.prof] -9.4288 3.7751 -2.498 0.01434 *
log(income):type[T.wc] -8.1556 4.4029 -1.852 0.06730 .



---
Signif. codes: 0 ' *** ' 0.001 ' ** ' 0.01 ' * ' 0.05 ' . ' 0.1 ' ' 1

Residual standard error: 6.409 on 89 degrees of freedom
(4 observations deleted due to missingness)
Multiple R-squared: 0.871, Adjusted R-squared: 0.8595
F-statistic: 75.15 on 8 and 89 DF, p-value: < 2.2e-16

As operações no modelo ativo podem ser selecionadas no menu Modelos. Por exemplo, 
Models → Hypothesis tests → Anova table..., seguidos pela seleção dos testes padrão "Tipo II", 
produz a seguinte saída:

> Anova(LinearModel.1, type="II")
Anova Table (Type II tests)
Response: prestige

Sum Sq Df F value Pr(>F)
education 1209.3 1 29.4446 4.912e-07 ***
log(income) 1690.8 1 41.1670 6.589e-09 ***
type 469.1 2 5.7103 0.004642 **
education:type 178.8 2 2.1762 0.119474
log(income):type 290.3 2 3.5344 0.033338 *
Residuals 3655.4 89
---
Signif. codes: 0 ' *** ' 0.001 ' ** ' 0.01 ' * ' 0.05 ' . ' 0.1 ' ' 1

Figura 16: A guia R Markdown, com o botão Generate report.



6 Outras Dicas
6.1 Produzindo relatórios
Em sua configuração padrão, o R Commander inclui uma guia R Markdown no painel superior, 
que acumula os comandos gerados durante a sessão em um documento R Markdown. A Figura 16 
mostra a guia R Markdown da sessão atual, que rolamos para a parte superior do documento gerado.
Como o próprio nome indica, o R Markdown é uma linguagem de marcação simples, que inclui 
blocos de comandos R e pode ser usada para gerar páginas HTML (ou seja, web) ou outros tipos de 
documentos. Para obter mais informações sobre o R Markdown, selecione Help → Using R 
Markdown nos menus do R Commander. 

Cada conjunto de comandos gerados pelo R Commander produz um bloco de comandos R 
no documento R Markdown. Esses blocos são delimitados por ```{r} no início de cada bloco e 
por ``` (três back-ticks) no final do bloco. Mesmo se você não estiver familiarizado com os 
comandos R, poderá ver o relacionamento entre comandos e a saída resultante no painel Output.

A guia R Markdown é editável e, portanto, você pode modificar e adicionar o texto na guia. 
Geralmente, é seguro digitar qualquer texto explicativo que você desejar entre os blocos de código 
R (veja abaixo). Em geral, no entanto, a menos que você saiba o que está fazendo, não modifique os
blocos de código R no documento R Markdown ou adicione seus próprios blocos de código. No 
entanto, é possível remover blocos inteiros de código, desde que os blocos subsequentes não 
dependam deles - e você provavelmente desejará remover blocos de comando que produzam 
resultados indesejados. Blocos de comando que produzem erros são removidos automaticamente. 
Você pode remover o bloco de comando mais recente selecionando Remove last Markdown 
Command Block no menu Edit ou clicando com o botão direito do mouse na guia R Markdown e 
selecionando Remove last Markdown Command Block no menu de contexto. O primeiro bloco de 
código (que começa com ``` {r echo = FALSE}) define algumas opções para o software do 
pacote knitr (Xie, 2013) usado para processar o texto R Markdown, e esse bloco normalmente 
não deve ser modificado. 

Com algumas linhas omitidas (indicadas por . . .), aqui está o documento R Markdown 
produzido para a sessão atual:

---
title: "Replace with Main Title"
author: "Your Name"
date: "AUTOMATIC"
---

``` {r echo=FALSE, message=FALSE}
# include this code chunk as-is to set options
knitr::opts_chunk$set(comment=NA, prompt=TRUE)
library(Rcmdr)
library(car)
library(RcmdrMisc)
```

``` {r echo=FALSE}
# include this code chunk as-is to enable 3D graphs
library(rgl)
knitr::knit_hooks$set(webgl = hook_webgl)
```



``` {r}
Nations <- read.table("C:/R/R-3.3.2/library/Rcmdr/etc/Nations.txt",
header=TRUE, sep="", na.strings="NA", dec=".", strip.white=TRUE)
```
.  .  .

``` {r}
data(Prestige, package="car")
```
.  .  .

Let us regress occupational prestige on the education and income levels of 
the occupations, transforming income to linearize its relationship to 
prestige:

``` {r}
LinearModel.1 <- lm(prestige ~ (education + log(income))*type,
data=Prestige)
summary(LinearModel.1)
```

``` {r}
Anova(LinearModel.1, type="II")
```

Provavelmente, é desnecessário explicar que você normalmente substituiria "Your Name" pelo seu 
nome e substituiria "Replace with Main Title" pelo título do relatório que deseja criar. Talvez 
menos obviamente, você pode digitar um texto explicativo arbitrário antes do primeiro bloco de 
comandos, entre os blocos de código R - isto é, entre o final ``` de um bloco e o início ```{r} do 
próximo '' - e após o último bloco de comandos. Você pode tirar proveito da marcação simples 
fornecida pelo R Markdown; por exemplo, o texto entre asteriscos (por exemplo, * isso é 
importante *) será definido em itálico. Para ilustrar, adicionamos o texto "Let us regress 
occupational prestige ..." imediatamente antes do bloco de comando R realizar a regressão.

Depois de terminar de editar o documento R Markdown, você pode gerar um relatório na 
forma de um documento HTML (página da web), documento do Word, arquivo rich text ou arquivo
PDF pressionando o botão Generate report abaixo da guia R Markdown. Um relatório HTML deve 
ser aberto no seu navegador da Web e um relatório em PDF no seu visualizador de PDF. Os 
arquivos do Word e Rich Text devem ser abertos manualmente, mas podem ser editados com 
facilidade. O documento R Markdown pode ser salvo no menu File.

Você também pode, e de forma mais conveniente, abrir uma janela do editor separada e 
maior para editar o documento R Markdown (consulte a Figura 17): Selecione Edit R Markdown 
document no menu R Commander Edit; clique com o botão direito do mouse na guia R Markdown 
e selecione Edit R Markdown document no menu de contexto; ou pressione a combinação de teclas 
Control-E quando o cursor estiver na guia R Markdown. O editor suporta os comandos usuais do 
menu Edit e clique com o botão direito do mouse no menu de contexto e também permite que você 
compile o documento R Markdown em um relatório HTML. Clicar no botão OK no editor salva as 



edições na guia R Markdown e clicar em Cancel descarta as edições. Abaixo do menu no editor, há 
uma barra de ferramentas amplamente auto-explicativa com vários botões; se você passar o mouse 
sobre um botão, uma “ferramente de dica” será exibida.

Você pode abrir a janela do editor R Markdown no início de uma sessão e deixá-la aberta 
enquanto trabalha. Os comandos gerados pelo R Commander serão inseridos na guia R Markdown 
e no editor, e você poderá escrever texto no editor à medida que avança. Veja a ajuda do editor para 
mais informações.

Figura 17: O editor de documentos R Markdown.

6.2 Salvando e imprimindo a saída
Você também pode salvar a saída de texto diretamente no menu File do R Commander; da mesma 
forma, você pode salvar ou imprimir um gráfico no menu File em uma janela R Graphics Device. 
Se você preferir não usar a guia R Markdown, poderá coletar a saída de texto e os gráficos que 



deseja manter em um documento de processador de texto. Dessa maneira, você pode intercalar a 
saída R com suas anotações e explicações digitadas. Esse procedimento, no entanto, tem a 
desvantagem de não ser diretamente reproduzível, enquanto um documento R Markdown pode ser 
executado posteriormente para reproduzir sua análise, possivelmente com modificações.

Abra um processador de texto como Word, OpenOffice Writer ou mesmo o Windows 
WordPad. Para copiar texto do painel Output, bloqueie o texto com o mouse, selecione Copy no 
menu Edit (ou pressione a combinação de teclas Ctrl-c ou clique com o botão direito do mouse no 
painel e selecione Copy no menu de contexto) e cole o texto no documento do processador de texto 
via Edit → Paste (ou Ctrl-v ou clique com o botão direito do mouse em Paste), como faria com 
qualquer aplicativo do Windows. Um ponto que vale a pena mencionar é que você deve usar uma 
fonte monoespaçada ("typewriter"), como Courier New, para saída de texto de R; caso contrário, 
a saída não será alinhada corretamente.

Da mesma forma, para copiar um gráfico, selecione File → Copy to clipboard → as a 
Metafile nos menus do dispositivo gráfico R; depois cole o gráfico no documento do processador de
texto via Edit → Paste (ou Ctrl-v ou clique com o botão direito do mouse em Paste). Como 
alternativa, você pode usar Ctrl-w para copiar o gráfico do R Graphics Device ou clicar com o botão
direito do mouse no gráfico para abrir um menu de contexto, no qual você pode selecionar Copy as 
metafile. No final da sua sessão R, você pode salvar ou imprimir o documento que criou, 
fornecendo um registro anotado do seu trabalho.

Maneiras alternativas para salvar texto e saída gráfica podem ser encontradas 
respectivamente nos menus R Commander File e Graphs → Save graph to file. Salvar a guia 
Script do R Commander, via File → Save script, permite reproduzir seu trabalho em uma ocasião 
futura.

6.3 Digitando comandos na guia Script
A guia R Script fornece um recurso simples para editar, inserir e executar comandos. Os comandos 
gerados pelo R Commander aparecem na guia Script e você pode digitar e editar comandos no
guia mais ou menos como em qualquer editor. O R Commander não fornece um "console" 
verdadeiro para R, no entanto, e a guia Script tem algumas limitações. Por exemplo, todas as linhas 
de um comando com várias linhas devem ser enviadas simultaneamente para execução. Para 
programação R séria, é preferível usar os editores de script fornecidos pelas versões Windows e 
Mac OS X do R, ou - melhor ainda - um editor de programação ou ambiente de desenvolvimento 
interativo, como o RStudio <www.rstudio.com>.

6.4 Usando plug-ins do R Commander
Os plug-ins do R Commander são pacotes R que aumentam os recursos do R Commander. 
Atualmente, muitos desses plug-ins estão disponíveis no CRAN e podem ser baixados e instalados 
da maneira normal. Os plug-ins normalmente adicionam menus ou itens de menu e caixas de 
diálogo associadas ao R Commander. Eles também podem modificar ou remover itens de menu ou
caixas de diálogo existentes. Um plug-in R Commander programado corretamente pode ser 
carregado diretamente, caso em que o R Commander carrega junto com o plug-in ou a partir do R 
Commander através de Tools → Load Rcmdr plug-in(s) .... No último evento, o R Commander 
será reiniciado para ativar o plug-in. É possível usar vários plug-ins simultaneamente, mas os plug-
ins também podem entrar em conflito entre si. Por exemplo, um plug-in pode remover um menu ao 
qual outro plug-in tenta adicionar um item de menu.

6.5 Finalizando a sessão R
Existem várias maneiras de encerrar sua sessão. Por exemplo, você pode selecionar File → Exit → 
From Commander and R nos menus do R Commander. Você será solicitado a confirmar e, em 



seguida, será perguntado se deseja salvar o conteúdo das janelas R Script, Output e R Markdown. 
Da mesma forma, você pode selecionar File → Exit do R Console; nesse caso, você será perguntado
se deseja salvar o espaço de trabalho R (ou seja, os dados que R mantém na memória); você 
normalmente responderia Não.
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